Bestandsnamen niet server/browser-vriendelijk

  • Rob Jakobs
  • Auteur

Bestandsnamen niet server/browser-vriendelijk

23 apr 2021 17:41 - 23 apr 2021 17:41
#40647
Ik heb gezocht of deze vraag eerder is gesteld en kon het niet vinden. Het verbaast me, want dit lijkt me toch een probleem dat meerdere gebruikers zouden moeten hebben, dus misschien doe ik iets fout.
Ik gebruik Aldfaer 8.1 met Windows 10.

Als ik een familielid heb, met voornaam José (dus met een accent op de e), wordt voor die persoon een html-bestand aangemaakt, waarbij in de bestandsnaam de letter é (met accent) voor komt, bijvoorbeeld jakobs_josé_53.html
Het gebruik van speciale karakters in bestandsnamen is zeer onverstandig (en waarschijnlijk niet volgens de internationale internetstandaard), omdat servers en browsers zich hierin kunnen 'verslikken' of deze gewoonweg niet accepteren.
De link vanuit de namenlijst (naam.html) werkt dan niet. Waarschijnlijk is het mijn Firefox-browser die de URL niet accepteert.Ik krijg de melding "The requested URL /stamboom/jakobs__josée_53.html was not found on this server". Je ziet dus dat het karakter é blijkbaar is vervangen door é De oorzaak zit hem in een of andere ISO/FT-8 omzetting.

Ik los het probleem op door de URL de betreffende bestanden handmatig te corrigeren en ook de bestandsnamen op de server dienovereenkomstig te wijzigen. Een vervelende klus die makkelijk voorkomen kan worden als Aldfaer geen 'rare' karakters meer gebruikt in de bestandsnamen.
Laatst bewerkt 23 apr 2021 17:41 door Rob Jakobs.

Lees meer

Re: Bestandsnamen niet server/browser-vriendelijk

23 apr 2021 18:07
#40648
Kunt u misschien vertellen met welk rapport dit is? Alle rapporten gebruiken naar mijn inzien het karaktercodeset utf-8

Lees meer

Re: Bestandsnamen niet server/browser-vriendelijk

23 apr 2021 18:22
#40649
Probeer eens met alle cookies en de cache op te ruimen in de opties.

Lees meer

Re: Bestandsnamen niet server/browser-vriendelijk

23 apr 2021 20:19
#40652
Dit is gewoon met het wizardrapport. We kijken ernaar.

Lees meer

Re: Bestandsnamen niet server/browser-vriendelijk

23 apr 2021 23:49
#40653
Onder de inhoud van een wizard-rapport uit mijn testbestand. Het rapport opent probleemloos in Firefox.

Lees meer

Re: Bestandsnamen niet server/browser-vriendelijk

24 apr 2021 08:46
#40655
Ja, dat klopt. Op een Windowsserver zal er dan ook geen probleem zijn. Maar je moet het ook testen onder Linux, want niet alle servers zijn Windows. En onder Linux stel ik wel problemen vast.

  • Rob Jakobs
  • Auteur

Re: Bestandsnamen niet server/browser-vriendelijk

24 apr 2021 11:20 - 24 apr 2021 11:22
#40656
Het is inderdaad met het wizard-rapport.
Het gebruik van speciale karakters in een bestandsnaam is zeer onwenselijk en tevens geheel onnodig, aangezien er ook een (volg)nummer wordt gebruikt.
Laatst bewerkt 24 apr 2021 11:22 door Rob Jakobs. Reden: typfout

Gemaakt door Kunena